Saltar al contenido

“El repositorio aún no es válido” ¿Error en Ubuntu Linux? ¡Aquí está la solución!

¿Se pregunta cómo solucionar el error “El repositorio aún no es válido” en Ubuntu Linux?

Una característica que hace de Linux un sistema operativo poderoso es su Interfaz de línea de comandos (CLI). Con la ayuda del terminal de Linux, puede realizar todo tipo de procesos escribiendo algunas líneas de comandos.

La CLI podría ser su mayor activo, ya que puede ayudarlo a ahorrar tiempo y a salir de apuros cuando la GUI no funciona, como un bloqueo del sistema. Tener un dominio de la CLI le brinda la ventaja que lo acerca un paso más a convertirse en un usuario profesional de Linux.

Ya sea que sea un usuario ocasional de Linux o un desarrollador profesional que usa una distribución de Linux, tendrá que encontrar la terminal de Linux en algún momento. Podría ser cuando instala aplicaciones o crea usuarios y grupos. Algunos comandos encontrarás más que otros, ya que son necesarios para que tus aplicaciones funcionen correctamente. Un ejemplo de dicho comando es $ sudo apt update.

Este comando descarga y actualiza la información del paquete relevante para su aplicación desde fuentes configuradas disponibles en Internet.

En algunos casos, sin embargo, no actualiza los repositorios según lo previsto. No importa cuántas veces intente ejecutar el comando, da un error que indica que los “Archivos de la versión no son válidos” junto con el enlace del recurso.

El repositorio aún no es válido

Si acabamos de describir su problema, no se preocupe, ya que esta guía le mostrará cómo puede deshacerse de este error, al tiempo que le proporciona una comprensión de por qué ocurre.

Aunque este tutorial se refiere a Ubuntu, no debería tener ningún problema al intentar hacer lo mismo con cualquier otra distribución de Linux.

Así que sin esperar más, ¡comencemos!

Comprensión del error.

Tener una idea de las causas del error le permitirá comprender mejor su sistema Linux y proporcionar información potencial sobre cómo corregir errores similares.

Lo más probable es que se encuentre con el error “El repositorio aún no es válido” en Ubuntu Linux al instalar y actualizar una aplicación o paquete usando el terminal de comandos, más específicamente cuando use el comando apt update. El mensaje de error debería ser el siguiente:

“El archivo de publicación para no es válido todavía (no es válido para otro ). No se aplicarán actualizaciones para este repositorio “.

El repositorio aún no es válido

Como se ve en el mensaje de error anterior, el paquete seguirá siendo inválido durante cierto tiempo, lo que significa que el error se debe a diferencias en la hora del sistema con el reloj mundial.

Puede verificar la hora del sistema escribiendo el siguiente comando

$ timedatectl
comando timedatectl

Como puede ver, el reloj del sistema no está sincronizado correctamente.

Ahora que hemos hablado de cómo se produce este error, podemos centrarnos en cómo solucionarlo. Siempre que siga los pasos, sincronizar el reloj del sistema con el reloj mundial será muy sencillo.

Sincronización del reloj del sistema [Terminal].

Sincronizar el reloj del sistema con el reloj mundial a menudo no requiere ningún trabajo. El simple hecho de conectarse a Internet debería sincronizar el reloj de su sistema. Si el reloj no se sincroniza, no se preocupe, ya que existen métodos para configurar manualmente el reloj en su fecha y hora local.

La mayoría de estos métodos utilizarán la terminal de comandos. Aunque pueda parecer abrumador, siempre y cuando sigas los pasos sincronizando el tiempo debería ser un paseo por el parque.

Para sincronizar el reloj de su sistema, siga estos pasos.

  1. Abre el mando Terminal presionando Ctrl + Alt + T.
  2. Una vez que se abre, escriba lo siguiente mando

$ sudo timedatectl set-local-rtc 1

  1. Escriba su clave y presione Ingresar.

Esto obligará al sistema a utilizar su reloj local como reloj de tiempo real. Puede cambiar el reloj de tiempo real para usar UTC escribiendo lo siguiente

$ sudo timedatectl set-local-rtc 0

Si siguió los pasos correctamente, entonces el reloj debería haberse sincronizado con la hora mundial. Puede verificar los cambios escribiendo el siguiente comando.

$ timedatectl.

Otra forma de sincronizar el reloj es usando el comando hwclock –hctosys. Para usar este comando, siga estos pasos.

  1. Abre el mando Terminal presionando Ctrl + Alt + T.
  2. Una vez que se abre, escriba lo siguiente mando.

$ sudo hwclock --hctosys

  1. Escriba su clave y presione Ingresar.

escriba la contraseña

Esto sincronizará el reloj de su hardware de acuerdo con la zona horaria seleccionada.

Si siguió los pasos correctamente, debe configurar el reloj del sistema según sea necesario. Ahora puede ejecutar el comando apt update sin ver el error “El repositorio aún no es válido” en Ubuntu Linux. Si cree que usar la terminal es complicado, siempre puede optar por el enfoque de GUI.

Sincronización del reloj del sistema [GUI].

Trabajar con el terminal puede no ser la mejor opción para todos. Si prefiere un enfoque más gráfico, lo cubrimos.

Siempre que siga los pasos correctamente, no debería tener ningún problema para sincronizar su reloj y, como verá, los pasos son simples y fáciles de entender.

Para arreglar el reloj de su sistema, siga estos pasos:

  1. Primero, ve a tu Escritorio de Ubuntuy haga clic en el Mostrar aplicaciones botón.

Escritorio de Ubuntu

  1. A continuación, tocando el Icono de configuración, o escribiendo “Ajustes” en el barra de búsqueda y hacer clic en el primer resultado debería ser suficiente.

icono de configuración

  1. Una vez hecho esto, escriba “Fecha y hora” en el Barra de búsqueda de configuración y haga clic en la primera opción.

fecha y hora

  1. Ver si el Fecha y hora automáticas la opción está habilitada; si no es así, haga clic en el control deslizante para habilitarlo. Esto debería sincronizar su reloj usando el Internet.
  2. Si eso no funciona para usted, intente configurar la hora manualmente a su hora local desactivando el Fecha y hora automáticas opción y haciendo clic en Fecha y hora. Esto le permitirá configurarlo manualmente.

El repositorio aún no es válido

  1. Cambie la fecha y la hora a su hora local y haga clic en el botón de cierre.

Si siguió estos pasos correctamente, la hora de su sistema ahora debería ser la misma que la hora local. Ahora puede intentar ejecutar el comando apt update sin enfrentar ninguna dificultad.

Con el reloj del sistema sincronizado, no debería enfrentarse al error “El repositorio aún no es válido” en Ubuntu Linux al intentar ejecutar el comando apt update. Esperamos que esta guía le haya ayudado a resolver su error y le haya proporcionado información sobre por qué ocurre y los pasos generales para solucionarlo.

Algunos usuarios también encuentran el error ‘E: No se pudo obtener lock / var / lib / dpkg / lock’ en Ubuntu Linux. Si eres uno de ellos, te recomendamos que consultes este artículo.

Si esta guía te ayudó, compártela. 🙂

( function( d, s, id ) {
var js, fjs = d.getElementsByTagName( s )[0];
if ( d.getElementById( id ) ) return;
js = d.createElement( s ); js.id = id;
js.src = “https://connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5&appId=305449883698649”;
fjs.parentNode.insertBefore( js, fjs );
}( document, ‘script’, ‘facebook-jssdk’ ) );

¡Haz clic para puntuar esta entrada!
(Votos: 0 Promedio: 0)